Please support mflenses.com if you need any graphic related work order it from us, click on above banner to order!

SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Horizontal white line in Sony Alpha7 RAW
View previous topic :: View next topic  

PostPosted: Mon May 30, 2022 7:28 am    Post subject: Horizontal white line in Sony Alpha7 RAW Reply with quote

Occasionally, I have an issue with a white horizontal line in the .arw files out of my Sony Alpha. Just recently, I took pictures on a birthday and they were all flawed. It cannot be nailed down to a certain lens or light situation, though much to my chagrin, it was just the Zuiko 50/1.2 on the camera that day. I like that lens a lot.
Here´s a sample:


Searching for the issue on the internet brought back some results, even from someone who built a tool to repair broken .arw Sony files through upload to his website. However, why this happens appears to remain a mystery. And it´s not some flaw that occurs only with vintage lenses, but occasionally also with Sony lenses built for the Alpha.

I opened the raw images after download from the SD card first time on an old laptop computer (sofa workstation Wink) and got the result as seen above. I used the Sony image viewer/editor software. Tried other editing software as well, with the same result.
Now the interesting thing about it is this:
Since this computer synchronizes via NAS with the other computer in my home office room, I opened the raw files a few days later again on the other machine and there were no stripes at all. Flawless.
The sofa computer is a HP Elitebook with onboard Intel graphics, whereas the office computer is a (younger, but also outdated) tower based on AMD Quad-Core and with NVIDIA GeForce 750Ti graphics card. So it´s probably a good hint once you have striped raws to try a different computer, but apart from that: any clue what´s going on here?

PostPosted: Sun Jun 12, 2022 4:48 am    Post subject: Reply with quote

Hey, no clue about the root cause but I can confirm that I have exactly the same problem on my A7. It’s affecting a few images every batch. Haven’t tried checking on different computers yet.

PostPosted: Sun Jun 12, 2022 9:46 am    Post subject: Reply with quote


Given the behaviour described (different for different computers), it would appear to be a software rather than hardware issue.

Since both of you refer to the SONY A7 (the oldest of the A7 line models), could it be an early firmware issue on the A7 which manifests itself differently depending on computer configuration / RAW editing software version?

And don't rule out 100% a faulty SD-card, as unintuitive as the behaviour may be... (file corruption may also manifest itself differently depending on RAW processing software/version).

PostPosted: Tue Jun 14, 2022 2:29 pm    Post subject: Reply with quote

RokkorDoctor wrote:

Since both of you refer to the SONY A7 (the oldest of the A7 line models)...

Mark, sorry for being imprecise. In my case it´s the A7ii. But from what I found out it´s not the only affected model, so it might as well happen occasionally with a Mk1.
Probably (though the issue seems to be similar, but not exactly the same) even on A6000 series cameras, as the link below suggests.


Thank you for the hint with the faulty SD-card. I have enough of those to try a different one, and this could be an easy fix.

PostPosted: Fri Apr 07, 2023 9:40 pm    Post subject: Reply with quote

I've seen similar white lines occassionally from RAW files from my A7II when I open the file in Photoshop. The line is there in the RAW Converter and when it opens in Photoshop. As soon as I do something to the image - anything - the line goes. And it doesn't print the line - I've tried.

I download my images using Sony Play Memories, then I generally use Faststone to view them initially ( It's quick and easy, I like it a lot ) I have never seen the white lines in Sony or Faststone. I have also gone back and looked at an image that shows a line in Photoshop to see if it's there in Sony or Faststone, and I have never seen one yet.

I've put it down to the Adobe Photoshop cloud based software being faster than my 6 year old high spec PC. It might be a different problem altogether, but it might be a software issue.