Home
SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Not getting any sharp pics with Tokina AT-X 90mm 2.5
View previous topic :: View next topic  


PostPosted: Sun Jul 05, 2020 5:01 pm    Post subject: Not getting any sharp pics with Tokina AT-X 90mm 2.5 Reply with quote

I have the lens with Canon FD mount and pics i take are not getting sharp. Changing aperture helps a bit but thats nothing i expect from a lens like the Tokina.
I already checked the position of each lens which is okay but cannot find out why there is this softness. Searching with google only brought me to one thread where somebody had the same problem and said that the is a problem with inter assembly spacing between front and middle lens unit.
So right now i'm looking for ideas, tutorials or pics which can help me to solve this problem.


PostPosted: Fri Jul 10, 2020 8:41 am    Post subject: Reply with quote

You might have a lens with a single lens or group mounted backwards.

It happened to me with a nikkor 35mm. It had been cleaned unprofessionally, a group had been mounted inverted. So it was more than soft, with things improving a bit by stopping down.

So you should look fort he lens diagram and see if your lens is in order under this point of view.


A single lens or group can enter in its place while inverted, sometimes, sometimes not.


When mounted correctly the lens was in an as new condition, crisp and clear