Home
SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Pentax Spotmatic - film release button problem
View previous topic :: View next topic  


PostPosted: Wed Aug 09, 2017 6:05 pm    Post subject: Pentax Spotmatic - film release button problem Reply with quote

Hi there,

New member, and wanted to know if anyone can help me with a Pentax Spotmatic.

The film release button on the baseplate is permanently depressed (a bit like myself). I have tried freeing it by removing the base plate, but to no avail. Also the button is not under any tension at all and appears quite loose, almost as if something is missing - a washer or spring maybe? I must point out that the camera is not jammed and the mirror is not locked up and the winder cocks the shutter, and the shutter fires.
If anyone can suggest anything useful or help in any way I would be most grateful.

Many thanks

Ian


PostPosted: Wed Aug 09, 2017 6:14 pm    Post subject: Reply with quote

Hi Ian, welcome to the forum.

Have you tried inserting a film in the camera and winding it on to the first exposure?


PostPosted: Wed Aug 09, 2017 6:32 pm    Post subject: Spotmatic Reply with quote

Thank you.

No I haven't tried that yet. I have only just bought the camera (knowing it to be faulty) after many years with digital. Fancied some old school!
Would loading a film make any difference do you think? Usually cocking the shutter is enough to pop out the release button.

Ian


PostPosted: Wed Aug 09, 2017 7:04 pm    Post subject: Spotmatic Reply with quote

I have run a test film through the camera now, and it won't wind the film on. I think I may be looking at a professional service and repair....


PostPosted: Wed Aug 09, 2017 7:17 pm    Post subject: Reply with quote

Ian, have a look here:

http://forum.mflenses.com/jammed-spotmatic-t7169.html


PostPosted: Wed Aug 09, 2017 7:29 pm    Post subject: Spotmatic Reply with quote

Hi Edgar,

Coincidentally I found that thread yesterday and tried the solution, but it did not do the trick. The problem is the camera is NOT jammed - everything functions perfectly, EXCEPT the film will not wind on because the film release button is stuck in the depressed position and the small spool with the cogs on it will not turn when the camera is wound on and hence the film will not advance.
I wish the camera was jammed, because now I know how to fix it! I have this feeling that there is something missing from around or under the release button - it just feels too loose.

Hmmmm. [/b]


PostPosted: Wed Aug 09, 2017 8:05 pm    Post subject: Reply with quote

If the button is in and you start to advance the film lever the button should pop out. I'm not an expert and it would seem the spring (or whatever) has broken (or moved out of position) that make the button pop out......none of my cameras have a loose button so as mentioned the spring keeps it tight.


PostPosted: Thu Aug 24, 2017 7:08 am    Post subject: Re: Spotmatic Reply with quote

Thomas wrote:
Hi Edgar,

Coincidentally I found that thread yesterday and tried the solution, but it did not do the trick. The problem is the camera is NOT jammed - everything functions perfectly, EXCEPT the film will not wind on because the film release button is stuck in the depressed position and the small spool with the cogs on it will not turn when the camera is wound on and hence the film will not advance.
I wish the camera was jammed, because now I know how to fix it! I have this feeling that there is something missing from around or under the release button - it just feels too loose.

Hmmmm. [/b]


Is your mirror locked in the up position also?