Home
SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Yashica ML 50 / 1.7. Strip down to clean aperture blades.
View previous topic :: View next topic  


PostPosted: Tue Feb 04, 2014 11:41 pm    Post subject: Yashica ML 50 / 1.7. Strip down to clean aperture blades. Reply with quote

I recently bought a bunch of Yashica equipment which included a Yashica ML 50 F1.7 that looked perfect, the body was unmarked, the glass was perfectly clear and the aperture blades looked good as well, but the blades were actually stuck solid and wouldn't open. Looking inside the lens with a torch they looked clean, but that was because there was an even layer of oil all over both sides of the aperture blades. I warmed the lens and the blades opened, and that's where they stayed, so it was time to open it up and clean it.

The lens is simple, and only requires a lens spanner for one ring, and wasn't tight so a small screwdriver might turn the ring using one slot.

Step one, put the lens on closest focus and grip the part that extends out the front. Grip the lens body by the rear lens cap which will 'unscrew' against the lens mount stops, do not grip the lens by the focus or aperture ring as it might strain the mechanisms. The extending part of the lens then unscrews from the body, it is fairly tight and rubber gloves might provide better grip, or even the kitchen tool for gripping tight jar lids. Mine unscrewed fairly easily with bare hands.


Looking at the front of the lens, with the deep ribbed conical trim still in place, you can now see the threaded ring with two slots for a lens spanner, unscrew this ring.


Once the threaded ring is removed there is nothing holding the complete optical assembly in place. In the picture you can see a small part sticking out of the front of the lens, pull on that and push the rear element. With a bit of pressure and wiggling about the optical block comes out. Make a note of it's orientation as it comes apart, although it can only go back one way and that is fairly obvious..

This is the empty lens body. A is the aperture lever from the aperture ring, this fits in the fork attached to the optical block ( B picture five ) as it is reassembled. You can see this, and manoeuvre it, through the back of the lens as it's reassembled. B is the slot where the guide slides, the offset washer held to the block with a small screw ( A picture five ).


This is the optical block. A is the block guide washer as it slides in the body. B is the forked aperture link from the aperture ring on the lens body. C is the stop down lever, this seemed to look after itself on reassembly and find it's correct position as long as the aperture cam was in the correct position - more on that later.
D and E are the lens elements, they each unscrew easily by hand. Be careful of the aperture return spring as you grip the optical block to unscrew the two sets of elements.


These are the two blocks of elements, both completely covered in the stickiest grease I've ever seen, The helicoid grease is red coloured, and this is what was everywhere inside this lens, not just a light smear of separated oil but actual grease. On the smaller element you can see some grease in a small pile that has somehow got past the threads holding the lens in place.
I washed the lenses in lighter fuel then soapy water, and finally cleaned them with lens cleaning fluid. ( Looking at both of these element sets I cannot see how they come apart, maybe they do, but it's not obvious and I didn't need to so I didn't try )


This is the empty optical block - all glass has been removed. The aperture mechanism and blades do not need to be dismantled or disturbed to wash the grease out. Again I used copious amounts of lighter fuel and cotton swabs, the grease is stubborn to dissolve and I used most of a tin of lighter fuel before the aperture blades were perfectly clean and snapped shut easily on the spring. I find it hard to figure out just how so much of this horrible grease could get so far inside the mechanism of this lens?
A is the aperture setting lever, B is the cam follower that rides on the cam - C. Just about visible is the follower on the highest point of the cam, which is the smallest aperture. If the lever D is pushed gently anticlockwise towards the copper coloured stop the lens will stop down, allowing full cleaning of the blades. E is the optical block to body guide.


This picture shows the cam and it's follower from a better angle, the follower A is attached to the grey metal lever ( to the left ) and the cam B is the black part closer to the center of the lens. The follower will fall off the end of the cam, and this does no harm, just lift the follower with your fingernail and move the cam with the forked lever. This is essential when reassembling the optical block back into the lens body. C is the stop down lever with the copper coloured stop above it.

Reassembly - screw the lenses back into the main optical block, set the cam follower on the high point of the cam. Line up the guide washer with the center slot in the lens body and gently reinsert. Look through the small gap at the rear of the lens and turn the aperture ring to move the lever in to the fork of the lever on the optical block. Looking at the lens, I think the black shroud secured by three screws will give much greater access if it is removed, but I managed with it in place. Use a head torch and you can see enough to line up the levers.
Once you think it is in place correctly the lens can be tested by just gently holding the block in place. If the aperture works correctly, refit the threaded securing ring, then the trim ring. Clean the lenses, and enjoy a great lens.


PostPosted: Thu Feb 13, 2014 3:32 pm    Post subject: Yashica 50 1.7 ML Different version Reply with quote

One of my older ML 50s was the same as you described. Thanks for the very clear procedure. Popped it apart as per instructions, cleaned sticky aperture and got it reassembled...although getting the fork aligned was iffy so I installed the lens "casing" first, got aperture working then screwed in front lens block and retaining ring, then screwed in rear lens group. Could see the alignment of the fork better without rear lens in place as it was reassembled. Next, another ML 50 1.7 with fungus issues in front lens group. However this must be a later version without the retaining ring to hold in the lens assembly...I wonder how to get the front lens group out. Maybe it simply unscrews, I didn't attempt to apply much torque on it.


PostPosted: Thu Feb 13, 2014 4:57 pm    Post subject: Reply with quote

I'm pleased the instructions helped, and it's also good to know there is more than one way to reassemble the lens and get the fork aligned, thank's for mentioning that.


PostPosted: Wed Jan 07, 2015 10:09 am    Post subject: Reply with quote

Dear David,

Links are broken. Is it possible to reanimate the pictures to your guide, please? Smile
I would love to see them, since a colleague has some oil on the blades.

Kind regards
Hasan


PostPosted: Mon Jan 12, 2015 9:47 pm    Post subject: Reply with quote

I'll have a look and see if they can be put back in the topic.


PostPosted: Tue Jan 13, 2015 11:53 am    Post subject: Reply with quote

The crash of the site servers just about coincided with the crash of my PC and backup storage, and sadly I haven't been able to find these pictures.


PostPosted: Tue Jan 13, 2015 6:09 pm    Post subject: Reply with quote

That's sad, from the documentary point of view.

Thanks anyway!


PostPosted: Wed Aug 28, 2019 10:58 am    Post subject: Reply with quote

Thanks for this post. I am cleaning my Yashinon Auto 1.8 55m.
As I clean the blades with lighter fluid I notice when they dry there is a dark film left.
Does that mean I need to continue cleaning?

Anyway now they are still sticky.


PostPosted: Wed Aug 28, 2019 12:48 pm    Post subject: Reply with quote

uddhava wrote:
Thanks for this post. I am cleaning my Yashinon Auto 1.8 55m.
As I clean the blades with lighter fluid I notice when they dry there is a dark film left.
Does that mean I need to continue cleaning?

Anyway now they are still sticky.


The only reliable way to clean aperture is to take it apart completely. For many lenses it is also faster than dipping into stinky solvent, then dying, then dipping it again, then drying, then dipping, and so on.