SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Issue with a Zenit E
View previous topic :: View next topic  

PostPosted: Wed Apr 18, 2018 1:01 pm    Post subject: Issue with a Zenit E Reply with quote

Hello, so i purchased for quite some money a Zenit 11 that came with a lens, seller mentioned it worked perfectly, but it had issues with the curtain (i think?), basically it was open as long as i kept the shutter button pressed (It wasn't in bulb, but it acted like that).

Now i bought a Zenit E body, and i tried it with the lens i got from the Zenit 11 (M42, Helios 44-4 58MM), the problem now is that i cannot change the apperture, the blades don't move at all. If i hold the lens in my hand and i press the pin on the back, it works, but if i have it attached on the Zenit E, nope.

I seem to be cursed.

PostPosted: Thu Apr 19, 2018 10:32 am    Post subject: Reply with quote

Zenit E doesn't have automatic aperture control. If the lens has an auto/manual switch, set it on manual and the aperture will be operated via aperture ring on the lens. If it doesn't have the switch. you'll have to improvise a solution to keep the pin depressed and then mount it on the camera.

PostPosted: Sat Jun 09, 2018 6:43 pm    Post subject: Reply with quote

Are you desperate for a Zenit camera?

I have an EM, TTL & 12 all in working order. Also a Praktika Super TL that is fine except for the flash x-sync (not an issue if you don't use flash).