Home
SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Tokina RMC 35mm 2.8 Focus Ring loose
View previous topic :: View next topic  


PostPosted: Sat Jun 29, 2013 5:48 am    Post subject: Tokina RMC 35mm 2.8 Focus Ring loose Reply with quote

Dear all

Just when I came to really love my Tokina 35mm f2.8, the focus ring came loose. Sure, you can still focus, but when you give it a firm twist it comes loose and you only move the ring and not the focus. Some lenses have screws that you can tighten the focus ring with. But I do not see them on my Tokina 35mm 2.8. I know it is not a lens seen often, but could somebody tell me if I can repair this myself without having to take the lens apart?

Great thanks and best regards,
Maarten


PostPosted: Thu Aug 01, 2013 4:50 pm    Post subject: Perhaps the same? Reply with quote

I'm a bit late here, but I ran into a similar issue with my Tokina AT-X 240 (24-40mm). The focus ring would move out and in, making it pretty much impossible to hold it in focus. I couldn't find any info, so I tore into it, and as such I believe I know how to fix yours.

What I found was that, under the rubber grip of the focus ring, you can gain access to some teflon spacers/washers. These allow the focus ring to move smoothly, while also keeping it from wobbling. I had to remove some scotch tape (which holds the front element onto the focusing ring - this is your issue, I think), then unscrew the front element and remove the focusing ring. I could then access the teflon spacers to replace/repair them.

For your issue, it's likely that the scotch tape holding the front element to the focus ring is no longer sticking. The solution is simply to re-tape it. I'm not sure if this is how they came from the factory, or if it had been worked on previously and that was the solution. At any rate, I replaced the tape on mine, and now it works perfectly.

By the way, I found the easiest way to remove the rubber grip is to twist the focus to infinity (or the other way, doesn't matter), then keep twisting until the rubber grip starts to stretch/buckle up. Then you can grab the part that's come up, and pull it out of the way.

I can post pictures, if you'd like.

Good luck!