Home
SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Leica R4s trouble.
View previous topic :: View next topic  


PostPosted: Mon Mar 12, 2018 11:39 pm    Post subject: Leica R4s trouble. Reply with quote

I can move the film transport lever all the way but there is no force to move it back and reset the shutter for another exposure, so when I push the release button, it goes down but nothing happens. How do I open the top cover and what do I need to look for in order to fix this problem?


PostPosted: Tue Mar 13, 2018 2:52 pm    Post subject: Reply with quote

Does it have power? In general though, Leica R bodies are notoriously unreliable.


PostPosted: Tue Mar 13, 2018 10:01 pm    Post subject: Reply with quote

Gardener wrote:
Does it have power? In general though, Leica R bodies are notoriously unreliable.


I don´t think it needs electric power to pull the handle back and reset the shutter. I think this should be forced back by a spring.


PostPosted: Wed Mar 14, 2018 8:24 pm    Post subject: Reply with quote

Gardener wrote:
Does it have power? In general though, Leica R bodies are notoriously unreliable.


Not all of them are! There are problems with R3 and R4 models. The later ones, esp. R6 and later, are pretty reliable.


PostPosted: Thu Mar 15, 2018 2:56 am    Post subject: Reply with quote

Problem solved. I opened undercover and by moving some parts of the mecanism I got it to work. I don´t know what I did or what the tecnical problem was, so I was very lucky with the result.