Home
SearchSearch MemberlistMemberlist RegisterRegister ProfileProfile Log in to check your private messagesLog in to check your private messages Log inLog in

Canon: EOS 40D and EOS 50D focusing screen
View previous topic :: View next topic  


PostPosted: Thu Jan 18, 2018 12:55 am    Post subject: Canon: EOS 40D and EOS 50D focusing screen Reply with quote

It seems these capable cameras are not the same, at least as far as mine have been:

I had a lovely split-circle/microprism focusing screen in my 40D(sold long ago),
which was an exact drop-in replacement for the factory screen. Focus was fully
accurate, auto-focus was fully accurate. I never missed a shot, whether auto-
or manual-focus. I only dropped it into the camera; nothing else.

Fast-forward to the newer 50D, and it's a different situation.
This is likely only a difference between camera bodies, rather than a difference
between the two models, simply because they both use the same screens.
I kept the same focusing screen I had been using after putting the factory screen
back into the camera and confirming accuracy before selling.

Because the two cameras take identical focusing screens, I expected the same results
with the very same focusing screen, but it was not so. My shots were most certainly
out of focus. I went back to finding and reviewing instructions for remedying this
unacceptable situation, with great results.

The primary reason for this post is to inform anyone with an issue getting a
focusing screen into the proper position, is that there was a brass shim which was against
the glass which holds the graphics for the auto-focus points and the center circle in my camera.
I did not expect such a situation, but all testing confirmed front-focus repeatedly.
Multiple instructions describe shimming the screen closer to the prism, but it did not
seem possible with my camera. So, I looked much closer.

It turned out that the brass 'frame' which appeared to be part of the AF-point glass assembly
WAS merely a shim. It seemed firmly in place at first, but later proved to be removeable.
I very carefully used a very thin razor knife to test the edges of it, which seemed to allow
some movement. It appeared to be held in place by something, however.
Upon further investigation, it turned out that the edge closest to the back of the camera
was somehow 'stuck' onto the glass, or maybe in a groove.
I went very carefully to that part of the shim with the super-fine knife,
and it popped free! After that shim was removed and placed carefully with the holder
of an original screen container, it took only one shot to determine that my
focus was spot-on! Smile

I have no scratches or other marks in my viewfinder other than the dust specks
that don't seem to budge, but it's completely in-focus now!

A very useful focusing chart due to use of greyscale:
regex.info/blog/photo-tech/focus-chart/


PLEASE NOTE:
Your results may differ. You might damage your camera if you attempt this!
I provide this information for anyone willing to take the proper precautions and risks.


PostPosted: Thu Jan 18, 2018 2:40 am    Post subject: Reply with quote

Thanks for sharing! I bet the stock screen is more accurate now too.


PostPosted: Thu Jan 18, 2018 10:40 pm    Post subject: Reply with quote

visualopsins wrote:
I bet the stock screen is more accurate now too.

I've no idea, and have no intention of finding out. Wink

I used the camera for a while with the stock screen and even the 'microfine' screen
(which was a generous gift from another forum member) without issue, but I've only
wanted a split-prism. Too bad I don't have the full-frame viewer, though! Embarassed


PostPosted: Thu Feb 01, 2018 8:10 am    Post subject: Reply with quote

Thanks for the great tip. Just took out mine to clean it, and it worked outclass!